<!DOCTYPE html>
<!-- Sorry no IE7 support! -->
<!-- @see http://foundation.zurb.com/docs/index.html#basicHTMLMarkup -->

<!--[if IE 8]><html class="no-js lt-ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en"> <!--<![endif]-->

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="google-play-app" content="app-id=com.bfi.bfi_sci_fi" />
<meta property="og:type" content="article" />
<meta name="apple-itunes-app" content="app-id=937838994" />
<link rel="shortcut icon" href="http://www.bfi.org.uk/sites/all/themes/bfi2013/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0" />
<meta name="description" content="What came out on top from our year of Blu-ray and DVD releases?" />
<meta property="og:description" content="What came out on top from our year of Blu-ray and DVD releases?" />
<meta property="og:image" content="http://www.bfi.org.uk/sites/bfi.org.uk/files/fb-images/rita-sue-and-bob-too-1987-001-siobhan-finneran-george-costigan-michelle-finneran-1000x750.jpg" />
<link rel="canonical" href="/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<link rel="shortlink" href="/node/46291" />
<meta property="og:url" content="http://www.bfi.org.uk/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017" />
<meta property="fb:app_id" content="190731001052619" />
<meta property="og:site_name" content="British Film Institute" />
<meta property="og:title" content="Top 10 bestselling BFI Blu-rays and DVDs of 2017" />
  <meta property="fb:pages" content="119827158059452" />
  <title>Top 10 bestselling BFI Blu-rays and DVDs of 2017 | BFI</title>
  <link type="text/css" rel="stylesheet" href="http://www.bfi.org.uk/sites/bfi.org.uk/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.bfi.org.uk/sites/bfi.org.uk/files/css/css_xgeO5nEz9clqfJtZ9W5UZ2T2n6nFOVt6kwBgmO8UQcE.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.bfi.org.uk/sites/bfi.org.uk/files/css/css_o22r_B_fCzPu7wSuv9e9x8tXofIBik4lfDr_sscOk4o.css" media="all" />
<style type="text/css" media="all">
<!--/*--><![CDATA[/*><!--*/
#sliding-popup.sliding-popup-bottom{background:#0779BF;}#sliding-popup .popup-content #popup-text h2,#sliding-popup .popup-content #popup-text p{color:#ffffff !important;}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="http://www.bfi.org.uk/sites/bfi.org.uk/files/css/css_kjkYIXCmeK7WRUdZ-uEMjgnziQm-z1izVqmQnhON6SQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.bfi.org.uk/sites/bfi.org.uk/files/css/css_cL6Cccr0oOqpSrKylWONB3oY8HiZwBcbfgTkKc6_Y6U.css" media="all" />
  <script type="text/javascript" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/js/js_ri60QNjcazMKdlAmWmDsmRb0iKaVkkXUQxH2MsgpmVo.js"></script>
<script type="text/javascript" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/js/js_F0wgh97uz557ex6Pn0ozddASaa90cfLuOinzSC9s7JU.js"></script>
<script type="text/javascript" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/js/js_I-1-VNHA5yjtCT7mo8B3XEDPfjHRdkNmkVQM9LQB_P4.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var _gaq = _gaq || [];_gaq.push(["_setAccount", "UA-2457994-1"]);_gaq.push(['_setDomainName', 'bfi.org.uk']);
_gaq.push(['_addIgnoredRef', 'bfi.org.uk']);_gaq.push(["_trackPageview"]);(function() {var ga = document.createElement("script");ga.type = "text/javascript";ga.async = true;ga.src = ("https:" == document.location.protocol ? "https://" : "http://") + "stats.g.doubleclick.net/dc.js";var s = document.getElementsByTagName("script")[0];s.parentNode.insertBefore(ga, s);})();
//--><!]]>
</script>
<script type="text/javascript" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/js/js_gIub-jf1DsP8Zjrmr1ftMmaJS7d6iOxoTE4LH-a4dfE.js"></script>
<script type="text/javascript" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/js/js_txPxiBxf8V3p9EHjRuApGBZadzhZ-e8KalsmxOQzZR8.js"></script>
<script type="text/javascript">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</script>
  <!--[if lt IE 9]>
    <script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
  <![endif]-->
  <script type="text/javascript" src="//use.typekit.net/ppi3hbr.js"></script>
  <script type="text/javascript">try{ Typekit.load();}catch(e){}</script>
  <script type="text/javascript" src="//cdn.optimizely.com/js/6286220731.js"></script>
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-46291 node-type-news" >
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-P9GRJK" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-P9GRJK');</script>
<!-- End Google Tag Manager -->
  <script>
    var versaTag = {};
    versaTag.id = "3423";
    versaTag.sync = 0;
    versaTag.dispType = "js";
    versaTag.ptcl = "HTTP";
    versaTag.bsUrl = "bs.serving-sys.com/BurstingPipe";
    //VersaTag activity parameters include all conversion parameters including custom parameters and Predefined parameters. Syntax: "ParamName1":"ParamValue1", "ParamName2":"ParamValue2". ParamValue can be empty.
    versaTag.activityParams = {
      //Predefined parameters:
      "Session":""
      //Custom parameters:
    };
    //Static retargeting tags parameters. Syntax: "TagID1":"ParamValue1", "TagID2":"ParamValue2". ParamValue can be empty.
    versaTag.retargetParams = {};
    //Dynamic retargeting tags parameters. Syntax: "TagID1":"ParamValue1", "TagID2":"ParamValue2". ParamValue can be empty.
    versaTag.dynamicRetargetParams = {};
    // Third party tags conditional parameters and mapping rule parameters. Syntax: "CondParam1":"ParamValue1", "CondParam2":"ParamValue2". ParamValue can be empty.
    versaTag.conditionalParams = {};
  </script>
  <script id="ebOneTagUrlId" src="http://ds.serving-sys.com/SemiCachedScripts/ebOneTag.js"></script>
  <noscript>
    <iframe src="http://bs.serving-sys.com/BurstingPipe?cn=ot&amp;onetagid=3423&amp;ns=1&amp;activityValues=$$Session=[Session]$$&amp;retargetingValues=$$$$&amp;dynamicRetargetingValues=$$$$&amp;acp=$$$$&amp;" style="display:none;width:0px;height:0px"></iframe>
  </noscript>

  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
      <!--ul class="title-area"-->
    <script type="text/javascript">var NREUMQ=NREUMQ||[];NREUMQ.push(["mark","firstbyte",new Date().getTime()]);</script>
  <div id="page_top" class="header row">
                <div class="block">
      
  <div class="content">
    <div class="header-row row">

  
<div class="small-12 columns desktop">

  <ul class="right single-line" id="sec-nav">
    <li class="desktop">
      <ul id="accessibility-menu">
        <li class="font-size"><p>Text size: <a class="current xsmall" href="#">A</a> <a class="small" href="#">A</a> <a href="#">A</a></p></li>
      </ul>
    </li>

          <li id="sec-menu-item-0" class="sec-nav-item sec-drop">
        <p><a href="http://www.bfi.org.uk/about-bfi" data-drop-content="sec-menu-item-0-children">About the BFI</a></p>
                  <ul id="sec-menu-item-0-children" class="drop-content">
                          <li><p><a href="http://www.bfi.org.uk/news-opinion/press-releases-media-enquiries" class="">Press releases and media enquiries</a></p></li>
                          <li><p><a href="http://www.bfi.org.uk/about-bfi/policy-strategy" class="">Policy and strategy</a></p></li>
                          <li><p><a href="http://www.bfi.org.uk/about-bfi/job-opportunities" class="">Job opportunities</a></p></li>
                          <li><p><a href="http://www.bfi.org.uk/about-bfi/business-services/selling-bfi" class="">Selling to the BFI</a></p></li>
                          <li><p><a href="http://www.bfi.org.uk/about-bfi/help-faq" class="">Help and FAQ</a></p></li>
                      </ul>
              </li>
          <li id="sec-menu-item-1" class="sec-nav-item sec-drop">
        <p><a href="http://www.bfi.org.uk/about-bfi/support-us-join" data-drop-content="sec-menu-item-1-children">Support & join</a></p>
                  <ul id="sec-menu-item-1-children" class="drop-content">
                          <li><p><a href="https://whatson.bfi.org.uk/Online/login.asp" class="">Sign up for emails</a></p></li>
                          <li><p><a href="http://www.bfi.org.uk/about-bfi/become-bfi-member" class="">Become a BFI Member</a></p></li>
                          <li><p><a href="http://www.bfi.org.uk/about-bfi/become-bfi-member/bfi-champion" class="">Become a BFI Champion</a></p></li>
                          <li><p><a href="http://www.bfi.org.uk/about-bfi/support-us-join/bfi-patrons" class="">Become a BFI Patron</a></p></li>
                          <li><p><a href="http://www.bfi.org.uk/about-bfi/support-us-join/make-donation-bfi" class="">Make a donation</a></p></li>
                          <li><p><a href="http://www.bfi.org.uk/about-bfi/support-us-join/corporate-support" class="">Corporate support</a></p></li>
                      </ul>
              </li>
          <li id="sec-menu-item-2" class="commercial sec-nav-item">
        <p><a href="http://player.bfi.org.uk" data-drop-content="sec-menu-item-2-children">Watch films on BFI Player</a></p>
              </li>
          <li id="sec-menu-item-3" class="commercial sec-nav-item sec-drop">
        <p><a href="http://www.bfi.org.uk/whats-on" data-drop-content="sec-menu-item-3-children">Tickets</a></p>
                  <ul id="sec-menu-item-3-children" class="drop-content">
                          <li><p><a href="https://whatson.bfi.org.uk/Online" class="">BFI Southbank tickets</a></p></li>
                          <li><p><a href="http://www.bfi.org.uk/bfi-imax" class="">BFI IMAX tickets</a></p></li>
                      </ul>
              </li>
          <li id="sec-menu-item-4" class="commercial sec-nav-item">
        <p><a href="http://shop.bfi.org.uk/" data-drop-content="sec-menu-item-4-children">BFI Shop</a></p>
              </li>
      </ul>
</div>

  <div class="clearer"></div>

  <div class="small-4 large-12 columns mobile mobile-hdr-icon" id="search-icon"><a href="#" title="Search">Search for mobiles</a></div>

  <div class="small-4 large-3 columns" id="logo"><a href="http://www.bfi.org.uk"><img src="http://www.bfi.org.uk/sites/all/themes/bfi2013/images/bfi_logo_transp.png" alt="BFI - homepage" title="BFI Film Forever logo - link to homepage" /></a></div>

  <div class="small-4 columns mobile mobile-hdr-icon" id="mobile-nav-icon"><a href="#" title="Main Nav - Additional">Main navigation for mobiles</a></div>

  <div class="small-12 columns" id="mobile-nav"></div>

  <div class="small-12 large-6 columns desktop" id="search">
      <form action="/bfi-suggestive-search/submit" method="post" id="bfi-suggestive-search-form" accept-charset="UTF-8"><div><div class="form-item form-type-textfield form-item-search-term">
 <input type="text" id="edit-search-term" name="search-term" value="I&#039;m looking for..." size="60" maxlength="128" class="form-text form-autocomplete" /><input type="hidden" id="edit-search-term-autocomplete" value="http://www.bfi.org.uk/index.php?q=bfi-suggestive-search/autocomplete" disabled="disabled" class="autocomplete" />
</div>
<input type="submit" id="edit-submit--2" name="op" value="" class="form-submit" /><input type="hidden" name="form_build_id" value="form-l6erf2oFRFlXmXaPCby90macEO31YqPsRhEPswx1UbA" />
<input type="hidden" name="form_id" value="bfi_suggestive_search_form" />
</div></form>  </div>

  <div class="small-12 large-12 columns" id="site-share">
    <a target="_blank" href="https://www.national-lottery.co.uk/life-changing/project-bfi-films"><img class="national-lottery-logo" src="http://www.bfi.org.uk/sites/all/themes/bfi2013/images/national-lottery-logo-color.png" alt="National Lottery" title="National Lottery" /></a>
    <ul class="site-share">
      <li id="bfi-fb">
        <div class="fb-like" data-href="https://www.facebook.com/BritishFilmInstitute" data-colorscheme="light" data-layout="button_count" data-show-faces="false"></div>
      </li>
      <li id="bfi-twitter">
        <a href="https://twitter.com/bfi" class="twitter-follow-button" data-show-count="true">Follow @bfi</a>
      </li>
      <li id="bfi-youtube">
        <div class="g-ytsubscribe" data-channel="BFIfilms" data-layout="default" data-count="default"></div>
      </li>
    </ul>
  </div>

  <div class="clearer"></div>

      <ul class="left" id="top-nav">
            <li class="mobile desktop" id="top_nav_1">
    <p><a href="http://www.bfi.org.uk/whats-on"  data-drop-content="drop-nav-1" class="medium expand button">What’s on</a>
      <span class="arrow"></span>    </p>
        <ul class="small-block-grid-3 drop-content" id="drop-nav-1">
      <li class="nav-sublist">
                <div class="box primary">
        <p class="h4">In this section</p>
        <ul>
                              <li><p><a href="http://player.bfi.org.uk" class="">BFI Player</a></p></li>
                    <li><p><a href="https://whatson.bfi.org.uk/Online/" class="">BFI Southbank</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/bfi-imax" class="">BFI IMAX</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/lff" class="">BFI London Film Festival</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/flare" class="">BFI Flare: London LGBT Film Festival</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/news-opinion/bfi-film-releases" class="">BFI film releases</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/whats-on/around-uk" class="">Around the UK</a></p></li>
                  </ul>
        </div>
                <div class="close-button"></div>
      </li>
      <li class="nav-highlight">
                <p class="h4">Highlight</p>
        <ul>
          <li>
          <!-- highlight -->
                    <a href="http://www.bfi.org.uk/thriller" class="">
            <img src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/site_wide_menu_highlights/public/who-can-you-trust-butterfly-artwork-1000x750.jpg?itok=lKBJskZg" alt="A season of thrillers in cinemas nationwide, at BFI Southbank and on BFI Player. - image" />
          </a>
          <p><a href="http://www.bfi.org.uk/thriller" class="">A season of thrillers in cinemas nationwide, at BFI Southbank and on BFI Player.</a><br />

                    </li>
        </ul>
              </li>
      <li class="nav-actions">
                <p class="h4">I want to&hellip;</p>
        <ul>
                      <li><p><a href="http://player.bfi.org.uk/" class="">Watch films online</a></p></li>
                      <li><p><a href="https://whatson.bfi.org.uk/Online/seasons" class="">Browse BFI Southbank seasons</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/distribution/contact_us" class="">Book a film for my cinema</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/international-touring-programmes" class="">Find out about international touring programmes</a></p></li>
                  </ul>
              </li>
    </ul>
      </li>
          <li class="desktop" id="top_nav_2">
    <p><a href="http://www.bfi.org.uk/explore-film-tv"  data-drop-content="drop-nav-2" class="medium expand button">Explore film & TV</a>
      <span class="arrow"></span>    </p>
        <ul class="small-block-grid-3 drop-content" id="drop-nav-2">
      <li class="nav-sublist">
                <div class="box primary">
        <p class="h4">In this section</p>
        <ul>
                              <li><p><a href="http://www.bfi.org.uk/explore-film-tv/films-tv-people" class="">Films, TV & people</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/news-opinion/news-bfi" class="">Latest from the BFI</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/news-opinion/sight-sound-magazine" class="">Sight & Sound magazine</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/news/50-greatest-films-all-time" class="">Best films of all time</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/archive-collections" class="">BFI National Archive</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/explore-film-tv/bfi-blu-rays-dvds" class="">BFI Blu-rays and DVDs</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/competitions" class="">Competitions</a></p></li>
                  </ul>
        </div>
                <div class="close-button"></div>
      </li>
      <li class="nav-highlight">
                <p class="h4">Highlight</p>
        <ul>
          <li>
          <!-- highlight -->
                    <a href="https://www.bfi.org.uk/best-films-2017" class="">
            <img src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/site_wide_menu_highlights/public/best-films-2017_1000x750.jpg?itok=Mgid5ctS" alt="Sight & Sound’s 25 best films of 2017 - image" />
          </a>
          <p><a href="https://www.bfi.org.uk/best-films-2017" class="">Sight & Sound’s 25 best films of 2017</a><br />

                    </li>
        </ul>
              </li>
      <li class="nav-actions">
                <p class="h4">I want to&hellip;</p>
        <ul>
                      <li><p><a href="http://www.bfi.org.uk/archive-collections/introduction-bfi-collections" class="">Find out more about the BFI National Archive</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/news-opinion/sight-sound-magazine/sight-sound-magazine-subscriptions" class="">Subscribe to Sight & Sound magazine</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/explore-film-tv/bfi-blu-rays-dvds" class="">Browse BFI Blu-rays and DVDs</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/news-opinion/news-bfi/lists" class="">Get film recommendations</a></p></li>
                  </ul>
              </li>
    </ul>
      </li>
          <li class="desktop" id="top_nav_3">
    <p><a href="http://www.bfi.org.uk/film-industry"  data-drop-content="drop-nav-3" class="medium expand button">Supporting UK film</a>
      <span class="arrow"></span>    </p>
        <ul class="small-block-grid-3 drop-content" id="drop-nav-3">
      <li class="nav-sublist">
                <div class="box primary">
        <p class="h4">In this section</p>
        <ul>
                              <li><p><a href="http://www.bfi.org.uk/supporting-uk-film/film-fund" class="">BFI Film Fund</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/supporting-uk-film/production-development-funding" class="">Production and development funding</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/supporting-uk-film/distribution-exhibition-funding" class="">Distribution and exhibition funding</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/about-bfi/policy-strategy/diversity" class="">Diversity</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/supporting-uk-film/skills-business-development-funding" class="">Skills and business development funding</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/supporting-uk-film/international-strategy" class="">International strategy</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/supporting-uk-film/british-certification-tax-relief" class="">British certification and tax relief</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/film-industry/funding-awards" class="">Search for Lottery awards</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/supporting-uk-film/bfi-distribution" class="">BFI Distribution</a></p></li>
                  </ul>
        </div>
                <div class="close-button"></div>
      </li>
      <li class="nav-highlight">
                <p class="h4">Highlight</p>
        <ul>
          <li>
          <!-- highlight -->
                    <a href="http://network.bfi.org.uk/" class="">
            <img src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/site_wide_menu_highlights/public/bfi-network-artwork-2017-02-1000x750.jpg?itok=TiEyduF6" alt="Discover how BFI NETWORK is supporting new and emerging filmmakers - image" />
          </a>
          <p><a href="http://network.bfi.org.uk/" class="">Discover how BFI NETWORK is supporting new and emerging filmmakers</a><br />

                    </li>
        </ul>
              </li>
      <li class="nav-actions">
                <p class="h4">I want to&hellip;</p>
        <ul>
                      <li><p><a href="http://www.bfi.org.uk/bfi-funded-films" class="">See projects backed by the BFI</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/film-industry/bfi-network" class="">Get help as a new filmmaker and find out about NETWORK</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/education-research/film-industry-statistics-research" class="">Read industry research and statistics</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/international-touring-programmes" class="">Find out about booking film programmes internationally</a></p></li>
                  </ul>
              </li>
    </ul>
      </li>
          <li class="desktop" id="top_nav_4">
    <p><a href="http://www.bfi.org.uk/education-research"  data-drop-content="drop-nav-4" class="medium expand button">Education & research</a>
      <span class="arrow"></span>    </p>
        <ul class="small-block-grid-3 drop-content" id="drop-nav-4">
      <li class="nav-sublist">
                <div class="box primary">
        <p class="h4">In this section</p>
        <ul>
                              <li><p><a href="http://www.bfi.org.uk/education-research/bfi-reuben-library" class="">BFI Reuben Library</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/education-research/education-events" class="">Education events</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/education-research/teaching-film-tv-media-studies" class="">Teaching film, TV and media studies</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/education-research/5-19-film-education-scheme-2013-2017/bfi-film-academy-scheme-2013-4" class="">BFI Film Academy</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/education-research/5-19-film-education-scheme-2013-2017/bfi-film-academy-scheme-2013-4" class="">5-19 Film Education Scheme 2013-2017</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/education-research/film-industry-statistics-research" class="">Film industry statistics and reports</a></p></li>
                  </ul>
        </div>
                <div class="close-button"></div>
      </li>
      <li class="nav-highlight">
                <p class="h4">Highlight</p>
        <ul>
          <li>
          <!-- highlight -->
                    <a href="http://www.bfi.org.uk/education-research/future-learning-skills" class="">
            <img src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/site_wide_menu_highlights/public/bfi-media-conference-2014-audience-during-alison-owen-opening-speech-20140703-1000x750.jpg?itok=YUFKzdFL" alt="Future learning and skills – giving everyone the opportunity to build a lifelong relationship with film. - image" />
          </a>
          <p><a href="http://www.bfi.org.uk/education-research/future-learning-skills" class="">Future learning and skills – giving everyone the opportunity to build a lifelong relationship with film.</a><br />

                    </li>
        </ul>
              </li>
      <li class="nav-actions">
                <p class="h4">I want to&hellip;</p>
        <ul>
                      <li><p><a href="http://www.bfi.org.uk/archive-collections/searching-access-collections" class="">Search the BFI National Archive collections</a></p></li>
                      <li><p><a href="https://whatson.bfi.org.uk/Online/education-events" class="">Browse our education events</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/education-research/education/education-resources" class="">Use film and TV in my classroom</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/education-research/film-industry-statistics-research" class="">Read research data and market intelligence</a></p></li>
                  </ul>
              </li>
    </ul>
      </li>
          <li class="mobile" id="top_nav_5">
    <p><a href="http://www.bfi.org.uk/about-bfi/help-faq"   class="medium expand button">Find us</a>
          </p>
      </li>
  </ul>
  
</div>
  </div>
</div>
      </div>

      <!-- Preface region -->
    <div class="row rel layout-box">
      <div class="block">
      
  <div class="content">
    <h2 class="element-invisible">You are here</h2><div class="breadcrumb"><a href="http://www.bfi.org.uk">Home</a> / <a href="/explore-film-tv">Explore film &amp; TV</a> / <a href="/taxonomy/term/926">Latest from the BFI</a> / <a href="/news-opinion/news-bfi/all">BFI news, features and opinion</a> / <a href="/news-opinion/news-bfi/features">Features</a></div>  </div>
</div>
    </div>
    <!-- /Preface region -->
  
  <!-- Intro row -->
  <div class="row layout-box">
    <!-- intro region -->
    <div id="region-intro" class="small-12 large-12 columns left layout-item layout-item-first">

      
            <div class="tabs"></div>                          <div class="block">
      
  <div class="content">
    <div id="node-46291" class="node node-news clearfix">

  
      
  
  <div class="content">
      </div>

  
  
</div>
  </div>
</div>
<div class="block">
      
  <div class="content">
    <div class="full-title ">
  
  <h1>
          Top 10 bestselling BFI Blu-rays and DVDs of 2017    
    
      </h1>

  
  
        <div class="copy">
              <div class="intro"><p>What came out on top from our year of Blu-ray and DVD releases?</p>
</div>
            
      
              <p class="author-data">
          <span class="date"><time datetime="2017-12-13">13 December 2017</time></span>        </p>
      
      
          </div>
  </div>
  </div>
</div>
<div class="block">
      
  <div class="content">
    
  <ul class="share">
          <li class="facebook_share"><div class="fb-share-button" data-href="http://www.bfi.org.uk/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017" data-layout="button_count"></div>
</li>
          <li class="field_tweetbutton"><div class="tweetbutton-tweet tweetbutton"><a href="http://twitter.com/share" data-size="medium" data-count="horizontal" data-via="" data-related=":" data-text="Top 10 bestselling BFI Blu-rays and DVDs of 2017" data-counturl="http://www.bfi.org.uk/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017" data-url="http://www.bfi.org.uk/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017" data-lang="" class="twitter-share-button">Tweet</a></div></li>
          <li class="pinterest"><a href="//pinterest.com/pin/create/button/?url=http://www.bfi.org.uk/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017&description=Top 10 bestselling BFI Blu-rays and DVDs of 2017&media=http://www.bfi.org.uk/sites/bfi.org.uk/files/news/rita-sue-and-bob-too-1987-001-siobhan-finneran-george-costigan-michelle-finneran-1000x750_0.jpg" data-pin-do="buttonPin" data-pin-config="beside" data-pin-zero="true"><img src="//assets.pinterest.com/images/pidgets/pin_it_button.png" /></a></li>
          <li class="google_plus"><div class="g-plusone" data-size="medium"></div></li>
      </ul>

  <div class='social_sidebar'>
  	<ul>
	            <li class="facebook_share"><div class="fb-share-button" data-href="http://www.bfi.org.uk/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017" data-layout="box_count"></div>
</li>
		          <li class="field_tweetbutton"><div class="tweetbutton-tweet tweetbutton"><a href="http://twitter.com/share" data-size="medium" data-count="vertical" data-via="" data-related=":" data-text="Top 10 bestselling BFI Blu-rays and DVDs of 2017" data-counturl="http://www.bfi.org.uk/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017" data-url="http://www.bfi.org.uk/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017" data-lang="" class="twitter-share-button">Tweet</a></div></li>
		          <li class="pinterest"><a href="//pinterest.com/pin/create/button/?url=http://www.bfi.org.uk/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017&description=Top 10 bestselling BFI Blu-rays and DVDs of 2017&media=http://www.bfi.org.uk/sites/bfi.org.uk/files/news/rita-sue-and-bob-too-1987-001-siobhan-finneran-george-costigan-michelle-finneran-1000x750_0.jpg" data-pin-do="buttonPin" data-pin-config="above"><img src="//assets.pinterest.com/images/pidgets/pin_it_button.png" /></a></li>
		          <li class="google_plus"><div class="g-plusone" data-size="tall"></div></li>
		      </ul>
  </div>

  </div>
</div>
<div class="block">
      
  <div class="content">
    <!-- ROS_LB -->
<div class="bfi-ads bfi-ad-lb show-for-medium-up" id='div-gpt-ad-1464088973033-1'></div>  </div>
</div>
<div class="block">
      
  <div class="content">
    <!-- ROS_MOBILELB -->
<div class="bfi-ads bfi-ad-mobilelb show-for-small" id='div-gpt-ad-1464088973033-2'></div>  </div>
</div>
<div class="block">
      
  <div class="content">
    <div class="small-12 large-12 columns solo">
  
  
  
  </div>


<div class="clear"></div>
  </div>
</div>
      
    </div>
  </div>

  <!-- Content row -->
  <div id="main-content" class="row layout-box">

          <div id="region-content-left-1" class="large-8 small-12 columns left layout-item layout-item-first">
        <div class="block">
      
  <div class="content">
    <div class="small-12 large-12 columns solo">
  
  
  
      <div class="wysiwyg"><h3>10. Céline and Julie Go Boating</h3>
<p><div class="image half">
  <img class="lazy lazy-hidden" data-aspect-ratio="0.756143667297" data-src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/celine-and-julie-go-boating-1974-blu-ray-packshot.jpg?itok=b77xclpP" alt="Céline and Julie Go Boating packshot" title="Céline and Julie Go Boating packshot" /><noscript><img  data-aspect-ratio="0.756143667297" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/celine-and-julie-go-boating-1974-blu-ray-packshot.jpg?itok=b77xclpP" alt="Céline and Julie Go Boating packshot" title="Céline and Julie Go Boating packshot" /></noscript>  </div>
</p>
<p>At over three hours, Adrian Martin&#8217;s new commentary on Jacques Rivette’s French New Wave classic is by far the longest we have released in 2017 – though it pales in comparison with Paul Cuff&#8217;s momentous feature-length commentary for the seven-hour Napoleon.</p>
<ul><li><a href="http://shop.bfi.org.uk/celine-and-julie-go-boating.html#.WikZ1TpLFPY">Buy Céline and Julie Go Boating</a></li>
</ul><h3>9. Daughters of the Dust</h3>
<p><div class="image half">
  <img class="lazy lazy-hidden" data-aspect-ratio="0.756143667297" data-src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/bfi-daughters-of-the-dust-dual-format-packshot.jpg?itok=zcuYukOh" alt="Daughters of the Dust packshot" title="Daughters of the Dust packshot" /><noscript><img  data-aspect-ratio="0.756143667297" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/bfi-daughters-of-the-dust-dual-format-packshot.jpg?itok=zcuYukOh" alt="Daughters of the Dust packshot" title="Daughters of the Dust packshot" /></noscript>  </div>
</p>
<p>Our new dual format (Blu-ray/DVD) edition was a welcome (and long overdue) upgrade for those collectors still hanging on to the VHS of Julie Dash&#8217;s film that we released on our Connoisseur label in 1993.</p>
<ul><li><a href="http://shop.bfi.org.uk/daughters-of-the-dust.html#.WjAHHlSFiUM">Buy Daughters of the Dust</a></li>
</ul><h3>8. Charlie Chaplin: The Essanay Comedies</h3>
<p><div class="image half">
  <img class="lazy lazy-hidden" data-aspect-ratio="0.755973563803" data-src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/chaplins-essanay-comedies-draft-artwork-blu-ray-packshot-2016.jpg?itok=CeiZhBtg" alt="Chaplin’s Essanay Comedies Blu-ray packshot (Draft artwork only)" title="Chaplin’s Essanay Comedies Blu-ray packshot (Draft artwork only)" /><noscript><img  data-aspect-ratio="0.755973563803" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/chaplins-essanay-comedies-draft-artwork-blu-ray-packshot-2016.jpg?itok=CeiZhBtg" alt="Chaplin’s Essanay Comedies Blu-ray packshot (Draft artwork only)" title="Chaplin’s Essanay Comedies Blu-ray packshot (Draft artwork only)" /></noscript>  </div>
</p>
<p>Our research for this release turned up a real rarity in the form of the 1951 British re-release version of A Burlesque on Carmen, which we discovered included a previously unknown voiceover by Peter Sellers.</p>
<ul><li><a href="http://shop.bfi.org.uk/hop-bfi-org-uk-dvd-blu-ray-chaplin-essany-dvd.html#.WikZsTpLFPY">Buy Charlie Chaplin: The Essanay Comedies</a></li>
</ul><h3>7. The Informer</h3>
<p><div class="image half">
  <img class="lazy lazy-hidden" data-aspect-ratio="0.753814852492" data-src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/informer-the-1929-013-dvd-bluray-disc-packshot.jpg?itok=hy4Vom55" alt="The Informer dual format edition packshot" title="The Informer dual format edition packshot" /><noscript><img  data-aspect-ratio="0.753814852492" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/informer-the-1929-013-dvd-bluray-disc-packshot.jpg?itok=hy4Vom55" alt="The Informer dual format edition packshot" title="The Informer dual format edition packshot" /></noscript>  </div>
</p>
<p>Made in 1929, this is one of the few British films to have been made as both a talkie and a silent. Our comprehensive dual format (Blu-ray/DVD) edition includes both versions.</p>
<ul><li><a href="http://shop.bfi.org.uk/the-informer.html#.WikZmTpLFPY">Buy The Informer</a></li>
</ul><h3>6. El sur</h3>
<p><div class="image half">
  <img class="lazy lazy-hidden" data-aspect-ratio="0.752911392405" data-src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/el-sur-draft-artwork-only-dual-format-packshot-2016.jpg?itok=3v3Xp-9q" alt="El Sur DVD and Blu-ray packshot (Draft artwork only)" title="El Sur DVD and Blu-ray packshot (Draft artwork only)" /><noscript><img  data-aspect-ratio="0.752911392405" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/el-sur-draft-artwork-only-dual-format-packshot-2016.jpg?itok=3v3Xp-9q" alt="El Sur DVD and Blu-ray packshot (Draft artwork only)" title="El Sur DVD and Blu-ray packshot (Draft artwork only)" /></noscript>  </div>
</p>
<p>Surprisingly El sur is only the second Spanish film in our DVD/Blu-ray catalogue, alongside the equally great Cría cuervos.</p>
<ul><li><a href="http://shop.bfi.org.uk/http-shop-bfi-org-uk-dvd-blu-ray-el-sur.html#.WikZhzpLFPY">Buy El sur</a></li>
</ul><h3>5. German Concentration Camps Factual Survey</h3>
<p><div class="image half">
  <img class="lazy lazy-hidden" data-aspect-ratio="0.751773049645" data-src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/german-concentration-camps-factual-survey-1945-2014-005-dvd-bluray-disc-packshot.jpg?itok=uCopIuxv" alt="German Concentration Camps Factual Survey dual format edition packshot" title="German Concentration Camps Factual Survey dual format edition packshot" /><noscript><img  data-aspect-ratio="0.751773049645" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/german-concentration-camps-factual-survey-1945-2014-005-dvd-bluray-disc-packshot.jpg?itok=uCopIuxv" alt="German Concentration Camps Factual Survey dual format edition packshot" title="German Concentration Camps Factual Survey dual format edition packshot" /></noscript>  </div>
</p>
<p>This hugely important film – restored over many years by the Imperial War Museum – was the subject of acclaimed doc Night Will Fall, one of our bestselling releases of 2015.</p>
<ul><li><a href="https://www.amazon.co.uk/German-Concentration-Factual-Survey-Blu-ray/dp/B01MUCTFK6">Buy German Concentration Camps Factual Survey</a></li>
</ul><h3>4. The Crying Game</h3>
<p><div class="image half">
  <img class="lazy lazy-hidden" data-aspect-ratio="0.756048387097" data-src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/crying-game-the-dual-format-edition-packshot.jpg?itok=Bal_x-Qm" alt="The Crying Game dual format edition packshot" title="The Crying Game dual format edition packshot" /><noscript><img  data-aspect-ratio="0.756048387097" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/crying-game-the-dual-format-edition-packshot.jpg?itok=Bal_x-Qm" alt="The Crying Game dual format edition packshot" title="The Crying Game dual format edition packshot" /></noscript>  </div>
</p>
<p>Ahead of this 25th anniversary, we welcomed director Neil Jordan and other members of the original cast and crew for an <a href="https://www.youtube.com/watch?v=HD2lhfB53Bs">on-stage event at BFI Southbank</a>.</p>
<ul><li><a href="http://shop.bfi.org.uk/pre-order-the-crying-game.html#.WikZSzpLFPY">Buy The Crying Game</a></li>
</ul><h3>3. Rita, Sue and Bob Too</h3>
<p><div class="image half">
  <img class="lazy lazy-hidden" data-aspect-ratio="0.75625" data-src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/rita-sue-and-bob-too-1986-dvd-bluray-disc-packshot-draft.jpg?itok=PS5_dCOd" alt="Rita, Sue and Bob Too dual format edition packshot" title="Rita, Sue and Bob Too dual format edition packshot" /><noscript><img  data-aspect-ratio="0.75625" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/rita-sue-and-bob-too-1986-dvd-bluray-disc-packshot-draft.jpg?itok=PS5_dCOd" alt="Rita, Sue and Bob Too dual format edition packshot" title="Rita, Sue and Bob Too dual format edition packshot" /></noscript>  </div>
</p>
<p>The release of this much-loved comedy leaves Billy the Kid and the Green Baize Vampire as the only one of Alan Clarke&#8217;s existing films not commercially available on Blu-ray.</p>
<ul><li><a href="http://shop.bfi.org.uk/rita-sue-and-bob-too.html#.WikZOjpLFPY">Buy Rita, Sue and Bob Too</a></li>
</ul><h3>2. Letter to Brezhnev</h3>
<p><div class="image half">
  <img class="lazy lazy-hidden" data-aspect-ratio="0.756048387097" data-src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/letter-to-brezhnev-1985-001-dvd-bluray-disc-packshot_0.jpg?itok=sbdV-3Ic" alt="Letter to Brezhnev dual format edition packshot" title="Letter to Brezhnev dual format edition packshot" /><noscript><img  data-aspect-ratio="0.756048387097" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/letter-to-brezhnev-1985-001-dvd-bluray-disc-packshot_0.jpg?itok=sbdV-3Ic" alt="Letter to Brezhnev dual format edition packshot" title="Letter to Brezhnev dual format edition packshot" /></noscript>  </div>
</p>
<p>Our artwork for this release was adapted from Jamie Reid&#8217;s original quad poster. Reid is best known as the designer of Sex Pistol&#8217;s Never Mind the Bollocks album (and is also the ex-husband of star Margi Clarke).</p>
<ul><li><a href="http://shop.bfi.org.uk/letter-to-brezhnev.html#.WikZKDpLFPY">Buy Letter to Brezhnev</a></li>
</ul><h3>1. The Wages of Fear</h3>
<p><div class="image half">
  <img class="lazy lazy-hidden" data-aspect-ratio="0.756143667297" data-src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/wages-of-fear-dual-format-packshot.jpg?itok=gk_XDYV_" alt="The Wages of Fear packshot" title="The Wages of Fear packshot" /><noscript><img  data-aspect-ratio="0.756143667297" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/wages-of-fear-dual-format-packshot.jpg?itok=gk_XDYV_" alt="The Wages of Fear packshot" title="The Wages of Fear packshot" /></noscript>  </div>
</p>
<p>This bestselling release marked the first time that the new 4K restoration of the original French theatrical cut – unveiled at Cannes in 2017 – has been available on Blu-ray anywhere in the world.</p>
<ul><li><a href="http://shop.bfi.org.uk/pre-order-the-wages-of-fear.html#.WipyOjpLFPY">Buy The Wages of Fear</a></li>
</ul></div>
  </div>


<div class="clear with-padding"></div>
  </div>
</div>
<div class="block">
      
  <div class="content">
    <div class="small-12 large-12 columns solo">
  
  
  
  </div>


<div class="clear"></div>
  </div>
</div>
      </div>
    
    
          <div id="region-content-right-1" class="small-12 large-4 columns right layout-item">
        <div class="block">
      
  <div class="content">
    <!-- ROS_MPU1 -->
<div class="bfi-ads" id='div-gpt-ad-1464088973033-3'></div>  </div>
</div>
<div class="block">
      
  <div class="content">
    
<div class="primary box single-item">

    <ul class="equalize xsmall-block-grid-1 small-block-grid-1 large-block-grid-1 with-bottom-margin">
          <li>
                <p class="h5"><a href='/news-opinion/news-bfi'>Latest from the BFI</a></p>
                            <a href="/news-opinion/news-bfi" ><img class="full" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/16x9_small/public/page/matter-of-life-and-death-a-1946-008-kim-hunter-david-niven-staring-ahead-1000x750.jpg?itok=px6u0PjY" alt="Latest from the BFI" /></a>
                <p>News, features and opinion on the world of film.
                        </p>
      </li>
      </ul>

      <p><a class="button medium expand" href="/news-opinion/news-bfi">Read more</a></p>
  
</div>

  </div>
</div>
<div class="block">
      
  <div class="content">
    
<div class="box multiple-items secondary">

  <h3>Further reading</h3>

  <ul class="side with-img-icon">
          
      <li>
        
        <a href="http://www.bfi.org.uk/sight-sound-magazine/best-dvds-blu-rays-2017"><img src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/16x9_small/public/news/dvds-blu-rays-of-2017_1000x750.jpg?itok=uf39VnYT" alt="The best Blu-rays (and DVDs) of 2017 - image" title="The best Blu-rays (and DVDs) of 2017 - image" /></a>
        <div class="content">
          <p class="h5"><a href="http://www.bfi.org.uk/sight-sound-magazine/best-dvds-blu-rays-2017">The best Blu-rays (and DVDs) of 2017</a></p>
                      <p class="authors"> Sight & Sound  contributors  </p>
                  </div>
        <div class="clear"></div>
      </li>
          
      <li>
        
        <a href="http://www.bfi.org.uk/news-opinion/news-bfi/features/celine-julie-go-boating-jacques-rivette-paris-locations"><img src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/16x9_small/public/news/celine-and-julie-go-boating-1974-024-juliet-berto-magician-1000x750.jpg?itok=vnrmgV2l" alt="How Paris has changed since Jacques Rivette shot Céline and Julie Go Boating in 1974 - image" title="How Paris has changed since Jacques Rivette shot Céline and Julie Go Boating in 1974 - image" /></a>
        <div class="content">
          <p class="h5"><a href="http://www.bfi.org.uk/news-opinion/news-bfi/features/celine-julie-go-boating-jacques-rivette-paris-locations">How Paris has changed since Jacques Rivette shot Céline and Julie Go Boating in 1974</a></p>
                      <p class="authors"> Oliver  Lunn  </p>
                  </div>
        <div class="clear"></div>
      </li>
          
      <li>
        
        <a href="http://www.bfi.org.uk/news-opinion/news-bfi/features/beyonce-lemonade-julie-dash-daughters-dust"><img src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/16x9_small/public/news/daughters-of-the-dust-1991-004-womanhood-1000x750.jpg?itok=WRvG0aUb" alt="Beyoncé vs Daughters of the Dust: How an American indie classic inspired Lemonade - image" title="Beyoncé vs Daughters of the Dust: How an American indie classic inspired Lemonade - image" /></a>
        <div class="content">
          <p class="h5"><a href="http://www.bfi.org.uk/news-opinion/news-bfi/features/beyonce-lemonade-julie-dash-daughters-dust">Beyoncé vs Daughters of the Dust: How an American indie classic inspired Lemonade</a></p>
                      <p class="authors"> Stephanie  Phillips  </p>
                  </div>
        <div class="clear"></div>
      </li>
          
      <li>
        
        <a href="http://www.bfi.org.uk/news-opinion/news-bfi/lists/henri-georges-clouzot-seven-essential-films"><img src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/16x9_small/public/news/diaboliques-les-1955-001-johnnie-walker-crime-00m-ko2-1000x750.jpg?itok=CMqGnkh-" alt="An introduction to Henri-Georges Clouzot in seven films - image" title="An introduction to Henri-Georges Clouzot in seven films - image" /></a>
        <div class="content">
          <p class="h5"><a href="http://www.bfi.org.uk/news-opinion/news-bfi/lists/henri-georges-clouzot-seven-essential-films">An introduction to Henri-Georges Clouzot in seven films</a></p>
                      <p class="authors"> Adam  Scovell  </p>
                  </div>
        <div class="clear"></div>
      </li>
          
      <li>
        
        <a href="http://www.bfi.org.uk/news-opinion/news-bfi/features/letter-brezhnev-liverpool-locations"><img src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/16x9_small/public/news/letter-to-brezhnev-1985-014-margi-clarke-alfred-molina-1000x750.jpg?itok=otjOyPnQ" alt="How Liverpool has changed since Thatcher-era classic Letter to Brezhnev - image" title="How Liverpool has changed since Thatcher-era classic Letter to Brezhnev - image" /></a>
        <div class="content">
          <p class="h5"><a href="http://www.bfi.org.uk/news-opinion/news-bfi/features/letter-brezhnev-liverpool-locations">How Liverpool has changed since Thatcher-era classic Letter to Brezhnev</a></p>
                      <p class="authors"> Oliver  Lunn  </p>
                  </div>
        <div class="clear"></div>
      </li>
          
      <li>
        
        <a href="http://www.bfi.org.uk/news-opinion/news-bfi/features/crying-game-london-locations"><img src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/16x9_small/public/news/crying-game-1992-001-00m-vm3-jaye-davidson-profile-stephen-rea-watching-1000x750.jpg?itok=X9OSc1qr" alt="How London has changed since The Crying Game - image" title="How London has changed since The Crying Game - image" /></a>
        <div class="content">
          <p class="h5"><a href="http://www.bfi.org.uk/news-opinion/news-bfi/features/crying-game-london-locations">How London has changed since The Crying Game</a></p>
                      <p class="authors"> Oliver  Lunn  </p>
                  </div>
        <div class="clear"></div>
      </li>
      </ul>

  
</div>
  </div>
</div>
      </div>
    
    
  </div>

  <!-- Outro row -->
  <div class="row layout-box">
          <div id="region-content-lower" class="small-12 large-12 columns left layout-item layout-item-last">
        <div class="block">
      
  <div class="content">
    
  <ul class="share">
        <li class="facebook_share"><div class="fb-share-button" data-href="http://www.bfi.org.uk/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017" data-layout="button_count"></div>
</li>
        <li class="field_tweetbutton"><div class="tweetbutton-tweet tweetbutton"><a href="http://twitter.com/share" data-size="medium" data-count="horizontal" data-via="" data-related=":" data-text="Top 10 bestselling BFI Blu-rays and DVDs of 2017" data-counturl="http://www.bfi.org.uk/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017" data-url="http://www.bfi.org.uk/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017" data-lang="" class="twitter-share-button">Tweet</a></div></li>
        <li class="pinterest"><a href="//pinterest.com/pin/create/button/?url=http://www.bfi.org.uk/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017&description=Top 10 bestselling BFI Blu-rays and DVDs of 2017&media=http://www.bfi.org.uk/sites/bfi.org.uk/files/news/rita-sue-and-bob-too-1987-001-siobhan-finneran-george-costigan-michelle-finneran-1000x750_0.jpg" data-pin-do="buttonPin" data-pin-config="beside" data-pin-zero="true"><img src="//assets.pinterest.com/images/pidgets/pin_it_button.png" /></a></li>
        <li class="google_plus"><div class="g-plusone" data-size="medium"></div></li>
      </ul>

  </div>
</div>
<div class="block">
      
  <div class="content">
    <h2 class="element-invisible">You are here</h2><div class="breadcrumb"><a href="http://www.bfi.org.uk">Home</a> / <a href="/explore-film-tv">Explore film &amp; TV</a> / <a href="/taxonomy/term/926">Latest from the BFI</a> / <a href="/news-opinion/news-bfi/all">BFI news, features and opinion</a> / <a href="/news-opinion/news-bfi/features">Features</a></div>  </div>
</div>
      </div>
    
  </div>

  <p class="mobile back-to-top"><a class="button expand secondary" href="#page_top">Back to the top</a></p>

  <!-- Footer row -->
  <div class="footer row rel">
    <div id="region-footer" class="small-12 columns">
      <div class="block">
      
  <div class="content">
    <div class="footer-row row">

      <ul class="footer-nav xsmall-block-grid-1 small-block-grid-2 large-block-grid-4">
          <li>
        <p class="h4"><a href="http://www.bfi.org.uk/whats-on">What’s on</a></p>
                            <ul>
                    <li><p><a href="http://player.bfi.org.uk">BFI Player</a></p></li>
                    <li><p><a href="https://whatson.bfi.org.uk/Online/">BFI Southbank</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/bfi-imax">BFI IMAX</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/news-opinion/bfi-film-releases">BFI film releases</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/whats-on/around-uk">Around the UK</a></p></li>
                    </ul>
                        </li>
          <li>
        <p class="h4"><a href="http://www.bfi.org.uk/explore-film-tv">Explore film & TV</a></p>
                            <ul>
                    <li><p><a href="http://www.bfi.org.uk/explore-film-tv/films-tv-people">Films, TV and people</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/news-opinion/news-bfi">Latest from the BFI</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/news-opinion/sight-sound-magazine">Sight & Sound magazine</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/news/50-greatest-films-all-time">Best films of all time</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/archive-collections">BFI National Archive</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/bfi-blu-rays-dvds-0">BFI Blu-rays and DVDs</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/news-opinion/competitions">Competitions</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/sitemap"> News and features archive</a></p></li>
                    </ul>
                        </li>
          <li>
        <p class="h4"><a href="http://www.bfi.org.uk/supporting-uk-film">Supporting UK film</a></p>
                            <ul>
                    <li><p><a href="http://www.bfi.org.uk/supporting-uk-film/film-fund">BFI Film Fund for filmmakers</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/supporting-uk-film/distribution-exhibition-funding">Funding for distributing and screening films</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/film-industry/funding-awards">Lottery funding awards</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/supporting-uk-film/international-strategy">International strategy</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/supporting-uk-film/skills-business-development-funding">Funding for organisations</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/supporting-uk-film/british-certification-tax-relief">British certification and tax relief</a></p></li>
                    </ul>
                        </li>
          <li>
        <p class="h4"><a href="http://www.bfi.org.uk/education-research">Education & research</a></p>
                            <ul>
                    <li><p><a href="http://www.bfi.org.uk/education-research/bfi-reuben-library">BFI Reuben Library</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/education-research/teaching-film-tv-media-studies">Teaching film, TV and media studies</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/education-research/5-19-film-education-scheme-2013-2017/bfi-film-academy-scheme">BFI Film Academy</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/education-research/into-film">5-19 Film Education Scheme 2013-2017</a></p></li>
                    <li><p><a href="http://www.bfi.org.uk/education-research/film-industry-statistics-research">Film industry statistics and reports</a></p></li>
                    </ul>
                        </li>
        </ul>
  
      <ul class="footer-nav xsmall-block-grid-1 small-block-grid-2 large-block-grid-4">
          <li>
        <p class="h4"><a href="http://www.bfi.org.uk/about-bfi">About the BFI</a></p>
                            <ul>
                      <li><p><a href="http://www.bfi.org.uk/about-bfi/support-us-join">Support the BFI</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/news-opinion/press-releases-media-enquiries">Press releases and media enquiries</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/about-bfi/policy-strategy">Policy and strategy</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/about-bfi/job-opportunities">Job opportunities</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/about-bfi/business-services/selling-bfi">Selling to the BFI</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/about-bfi/help-faq">Help and FAQ</a></p></li>
                    </ul>
                        </li>
          <li>
        <p class="h4"><a href="http://www.bfi.org.uk/">More from the BFI</a></p>
                            <ul>
                      <li><p><a href="http://www.bfi.org.uk/bfi-membership">BFI Members</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/about-bfi/business-services/venue-hire">Venue hire</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/venue-hire/bfi-stephen-street-venue-hire">Viewing theatre hire</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/archive-collections/archive-content-sales">Archive content sales and licensing</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/distribution/contact_us">Book a film for your cinema</a></p></li>
                      <li><p><a href="http://www.bfi.org.uk/archive-collections/archive-content-sales/stills-sales">Stills sales</a></p></li>
                    </ul>
                        </li>
          <li>
        <p class="h4"><a href="http://www.bfi.org.uk/">Connect with us</a></p>
                            <ul>
                      <li><p><a href="https://facebook.com/BritishFilmInstitute"><img class="menu-icon-20x20" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/menu_image_20x20/public/menuimage/bfi-social-icon-facebook-40x40.png?itok=Oo6raA_O" />Facebook</a></p></li>
                      <li><p><a href="https://twitter.com/bfi"><img class="menu-icon-20x20" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/menu_image_20x20/public/menuimage/bfi-social-icon-twitter-40x40.png?itok=LiuxNNr0" />Twitter</a></p></li>
                      <li><p><a href="https://instagram.com/britishfilminstitute"><img class="menu-icon-20x20" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/menu_image_20x20/public/menuimage/bfi-social-icon-instagram-40x40.png?itok=CH4_GMiS" />Instagram</a></p></li>
                      <li><p><a href="https://www.youtube.com/user/BFIfilms"><img class="menu-icon-20x20" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/menu_image_20x20/public/menuimage/bfi-social-icon-youtube-40x40.png?itok=-wkh1ke0" />YouTube</a></p></li>
                      <li><p><a href="https://www.pinterest.com/bfionline/"><img class="menu-icon-20x20" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/menu_image_20x20/public/menuimage/bfi-social-icon-pinterest-40x40.png?itok=IE___2Un" />Pinterest</a></p></li>
                      <li><p><a href="http://britishfilminstitute.tumblr.com/"><img class="menu-icon-20x20" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/menu_image_20x20/public/menuimage/bfi-social-icon-tumblr-40x40.png?itok=Q2B3f86q" />Tumblr</a></p></li>
                      <li><p><a href="https://plus.google.com/+britishfilminstitute"><img class="menu-icon-20x20" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/menu_image_20x20/public/menuimage/bfi-social-icon-google-40x40.png?itok=4i2mzlFf" />Google+</a></p></li>
                    </ul>
                        </li>
        </ul>
  
  <div class="footer-strip">

    <ul class="sep-list">
      <li><p><a href="http://www.bfi.org.uk/terms-use">Terms of use</a></p></li>
      <li><p><a href="http://www.bfi.org.uk/tickets-other-purchases-bfi-southbank">BFI Southbank purchases</a></p></li>
      <li><p><a href="http://www.bfi.org.uk/bfi-online-community-guidelines">Online community guidelines</a></p></li>
      <li><p><a href="http://www.bfi.org.uk/cookies-privacy">Cookies and privacy</a></p></li>
    </ul>
    <p>&copy;2017 British Film Institute. All rights reserved. Registered charity 287780.</p>

  </div>
</div>
  </div>
</div>
    </div>
  </div>
  <script type="text/javascript">if(!NREUMQ.f){NREUMQ.f=function(){NREUMQ.push(["load",new Date().getTime()]);var e=document.createElement("script");e.type="text/javascript";e.src=(("http:"===document.location.protocol)?"http:":"https:")+"//"+"js-agent.newrelic.com/nr-100.js";document.body.appendChild(e);if(NREUMQ.a)NREUMQ.a();};NREUMQ.a=window.onload;window.onload=NREUMQ.f;};NREUMQ.push(["nrfj","bam.nr-data.net","b3d0337ff6","17585329","b1ZTNRQHWERZUxFRWlYccAISD1lZF14KXFBnQ1AGAzlAXl1H",0,893,new Date().getTime(),"","","","",""]);</script>  <div id="bfi-email-signup-overlay">
  <div id="bfi-email-signup-container">
    <div id="bfi-email-signup-text-container"><div class="wysiwyg"><p><div class="image half">
  <img class="lazy lazy-hidden" data-aspect-ratio="8.54700854701" data-src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/bfi-player-logo-2000x234.png?itok=C2GoSVSk" alt="" title="" /><noscript><img  data-aspect-ratio="8.54700854701" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/styles/half/public/image/bfi-player-logo-2000x234.png?itok=C2GoSVSk" alt="" title="" /></noscript>  </div>
</p>
<h4>See something different</h4>
<p>Subscribe now for exclusive offers and the best of cinema.<br />
	Hand-picked.</p>
</div></div>
    <div id="bfi-email-signup-form-container"><form class="webform-client-form" action="/news-opinion/news-bfi/features/top-10-bestselling-bfi-blu-rays-dvds-2017" method="post" id="bfi-email-signup-form" accept-charset="UTF-8"><div><div class="bfi-email-signup-validation">Please enter a valid email</div><div class="form-item form-type-textfield form-item-email">
  <label for="edit-email">Email </label>
 <input class="bfi-email-signup-email with-placeholder form-text" type="text" id="edit-email" name="email" value="Type your email here for free updates" size="60" maxlength="128" />
</div>
<input class="bfi-email-signup-submit form-submit" type="submit" id="edit-submit" name="op" value="Subscribe" /><input class="bfi-email-signup-decline form-submit" type="submit" id="edit-decline" name="op" value="No thanks" /><input type="hidden" name="form_build_id" value="form-N8qj1K09L9YU2VpVffza9NWGzlMv2tu4RJ8MOMGjg9s" />
<input type="hidden" name="form_id" value="bfi_email_signup_form" />
</div></form></div>
  </div>
</div>  <div id="fb-root"></div>
  <script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_GB/all.js#xfbml=1&appId=190731001052619";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));</script>      <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>    <script type="text/javascript">
    (function() {
      var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
      po.src = 'https://apis.google.com/js/plusone.js?onload=onLoadCallback';
      var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
    })();
  </script>  <script type="text/javascript">
  (function(d){
      var f = d.getElementsByTagName('SCRIPT')[0], p = d.createElement('SCRIPT');
      p.type = 'text/javascript';
      p.async = true;
      p.src = '//assets.pinterest.com/js/pinit.js';
      f.parentNode.insertBefore(p, f);
  }(document));
  </script><script type="text/javascript" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/js/js_paiTaEsc1HNeBS2rkLc1NrprKrFnApv70kuY8awAaTI.js"></script>
<script type="text/javascript" src="https://apis.google.com/js/platform.js"></script>
<script type="text/javascript" src="http://www.bfi.org.uk/sites/bfi.org.uk/files/js/js_X82WBq_emB_xzN_cVdoMzowicGaSo_qtj1xUbgQkTuU.js"></script>
  <script>
    (function ($, Drupal, window, document, undefined) {
      $(document).foundation();

      $('#top-nav').dropClick();
      $('#sec-nav').dropClick({ 'selector': ' > li.sec-drop' });
      $('#accessibility-menu .font-size').on('click', 'a', function( e ) { $(this).parent().find('a').removeClass('current'); $(this).addClass('current'); $('html').css('font-size', (62.5 + 12.5*$(this).index()).toString() + '%'); });
      $('#search-icon a').click(function(){ $('#mobile-nav').slideUp(100); $('#search').slideToggle(500); });
      $('#mobile-nav').append('<ul />');
      $('#top-nav > li:not(.mobile)').each( function() { $('#mobile-nav ul').append( '<li><p>' + $(this).find('>p').html() + '</p></li>'); });
      $('#mobile-nav-icon a').click(function(){ $('#mobile-nav').slideToggle(500); $('#search').slideUp(100); });
      $(':not(#qunit-fixture) > [data-bfi-gallery]').gallery();
      $('.equalise[class*=-block-grid-]').equalHeight();
      $('.twitter-feed:first').twitterFeed();
      $('body').responsiveTable();
      $('#bfi-suggestive-search-form #edit-submit').attr('value', 'Search');

      $('html.lt-ie9').each( function() { fixIe8LastChild() });

      window.resizeStatus = 'done';
      $(window).on('resize', bfiResize );
      $(window).trigger('resize');

    })(jQuery, Drupal, this, this.document);
  </script>

</body>
</html>
